1. 小媛啾首页
  2. 科技新闻
  3. 最新科技新闻

Saurik预计在12月将会替Cydia Impactor更新,修正Xcode 7.3错误

由于苹果服务器改变机制,导致不少用户使用Cydia Impactor来重签时,就会出现「Please update to Xcode 7.3 or later to continue developing with your Apple ID.」错误讯息,造成无法重签灾难,对于这问题越狱之父Saurik也已经于推特表示将会修补Cydia Impactor错误,不过时间预计在12月中旬才会释出更新档。

针对这项错误,Saurik 也已经仔细分析,确认Cydia Impactor 所造成的错误,最主要原因是因为两周前,Apple突然对伺服器进行了修改,其实也是替「免费」开发者帐号要求不同的身分认证方案,所以才会导致一直跳出错误讯息,要求升级到Xcode 7.3 错误讯息,造成无法重签。

Saurik预计在12月将会替Cydia Impactor更新,修正Xcode 7.3错误

突如其来的更改,恰好Saurik 正在美国佛罗里达当朋友婚礼上的伴郎,在采排前一晚也仔细了解Cydia Impactor 为什么为出现这项错误,并且尝试想用最短时间去修补,发现到这项错误太过于复杂,牵扯到多个平台,像是macOS、Windows 和Linux,因此要花费大约依周时间才能针对Apple 的代码进行反向工作,也许后续可能会选择放弃Linux支援,只针对Windows 和macOS 版本推出;不过Saurik表示依旧是以婚礼为主,等后续有空在来处理这项错误,预计会在12月份才会推出Cydia Impactor 更新。

如果你现在想要解决Chimera 、Electra或unc0ver越狱重签问题,那有底下几种方案

  • 等待12月Saurik推出Cydia Impactor修正
  • 缴99美元直接成为年付费开发者
  • 直接使用免电脑版工具下载(苹果随时会撤销凭证)

 

如果使用还在使用免电脑版用户,比较建议改采用「自动重签ReProvision」工具,主因是ReProvision已经修正这项错误,而且就不需依赖电脑或网页版重签问题,如果你现在依旧待在越狱环境,建议不要随意重开机,因为现在Cydia Impactor已经无法使用,网页版又随时会出现无法安装问题。

假如是iPhone 5S~iPhone X 设备,比较建议采用checkra1n 来越狱,不过这款越狱工具目前止能够在macOS 系统上执行,完全不需要依赖Cydia Impactor 工具。

发布者:yuanyuan,转转请注明出处:https://www.xiaoyuanjiu.com/13349.html

发表评论

登录后才能评论